Terug naar overzicht
Opgelost
nexttel.nl Website is offline
Aug 5, 2026 at 8:37am UTC
Getroffen services
nexttel.nl Website
Opgelost
Aug 5, 2026 at 8:41am UTC
nexttel.nl Website is hersteld.
Getroffen services
Aangemaakt
Aug 5, 2026 at 8:37am UTC
nexttel.nl Website is offline gegaan.
Getroffen services