Terug naar overzicht
Opgelost

nexttel.nl Website is offline

Aug 4, 2026 at 5:41pm UTC
Getroffen services
nexttel.nl Website

Opgelost
Aug 4, 2026 at 5:46pm UTC

nexttel.nl Website is hersteld.

Aangemaakt
Aug 4, 2026 at 5:41pm UTC

nexttel.nl Website is offline gegaan.