Terug naar overzicht
Opgelost

nexttel.nl Website is offline

Aug 20, 2026 at 3:33pm UTC
Getroffen services
nexttel.nl Website

Opgelost
Aug 20, 2026 at 9:56pm UTC

nexttel.nl Website is hersteld.

Bijgewerkt
Aug 20, 2026 at 9:52pm UTC

nexttel.nl Website is offline gegaan.

Bijgewerkt
Aug 20, 2026 at 5:44pm UTC

nexttel.nl Website is hersteld.

Bijgewerkt
Aug 20, 2026 at 5:40pm UTC

nexttel.nl Website is offline gegaan.

Bijgewerkt
Aug 20, 2026 at 3:43pm UTC

nexttel.nl Website is hersteld.

Aangemaakt
Aug 20, 2026 at 3:33pm UTC

nexttel.nl Website is offline gegaan.