Terug naar overzicht
Opgelost

nexttel.nl Website is offline

Aug 11, 2026 at 2:13pm UTC
Getroffen services
nexttel.nl Website

Opgelost
Aug 11, 2026 at 2:17pm UTC

nexttel.nl Website is hersteld.

Aangemaakt
Aug 11, 2026 at 2:13pm UTC

nexttel.nl Website is offline gegaan.